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Tools  
All viewing options are selected by default. Unselect these options to change the Trace View settings. 

 
Save  
Save the Trace View image as a Bitmap (.bmp) file. 

 

Merge Projects 
 
The Merge Projects Application is available directly from the opening GeneMarker Screen or from the Tools 
drop-down menu. After each project is analyzed with the appropriate panel the results may be combined using 
this tool. A common challenge for Kinship calculations or cluster analysis in animal and plant populations is 
obtaining enough informative markers in one multiplex. Overlapping marker ranges and/or incompatible 
chemistry make it necessary to run the same samples multiple times with different sets of marker primers. 
Human disease diagnostic research also my require more than one kit (multiplex) to obtain the full range of 
allele calls as with Duchenne’s Muscular Dystrophy or Cystic Fibrosis. 
 
By following a naming convention where the individual identifier and the panel identifiers are consistent, 
researchers can combine the individual results from multiple panel analyses into one report, providing a more 
complete genotype for each sample.  This merged report may be imported into other special applications (such 
as Clustering Analysis or Relationship Testing) to improve the robustness of the results by including information 
from more markers. 
 

Procedure 
1. Save each project for a set of individual files (Please see 

Chapter 2 General Procedure) Note: Allele editing and 
resolution of any flagged allele calls must be done prior 
to saving each project and importing results into the  
Merge Project Tool. 

2. Open Merge Projects from the Tool Drop-down menu 
or the Open Folder icon  

3. Projects � Merge Projects �Add project files �OK 
4. Report Grouping icon activates the 

Grouping screen 
5. Match by Section, Fixed Position or 

Group Order �Match �OK 
Note: To simplify this task separate the group identifier 
and the exact control identifier by an underscore or 
have the same number of spaces for the individual and 
group identifiers in a file name. For example – if the 
individual’s identification number is 12345 and it will 
be analyzed with panel XYZ and panel ABC separate 
the sections by an underscore when applying the 
sample to the genetic analyzer. 
Project with XYZ   Project with ABC 
12345_XYZ_A01   12345_ABC_A01 
12346_XYZ_A02   12346_ABC_A02 
12347_XYZ_A03   12347_ABC_A03 

 
6. Use the Report Icon to activate the Allele Report Settings  
7. Select appropriate format : 

For example: Select Bin Table and deselect Show Peak  
Area for combined reports that will be used in Cluster Analysis or 
Select Marker Table (Fragment) for combined reports that will be 
used in Relationship Testing 

8. Save the merged project report as a .txt file. Note: The file name will 
automatically read from the current project. Users may want to use a 
specific file name for the merged project report. 
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 Icons and Functions 
 

Load Files 
Activates a dialog box to open the project files to allow 
merging of allele reports 

 
Report Grouping 
Activates the report grouping to allow combining allele reports of the same samples that were 
produced from different multiplexes 

 
 
Allele Report Settings 
Allows selection of the appropriate allele report settings for each analysis type 
 

 
Save 
Save the combined allele report as a .txt file for use in applications such as Cluster Analysis or 
Relationship Testing 

 
 

Export Allele Frequency Table 
A formatting tool to assit with importing allele frequency tables in the Relationship Testing 
application. The table contains the markers and all bins (based on the combined project panels). The 

‘frequency’ value is 1/number of bins. This provides formatting or space holders for the user to enter the actual 
allele frequencies based on their population information. Alternatively, see chapter 7, Relationship testing for 
allele frequency format description.  
 
 
 
 

Functions 
 

Match by Sections 
Automatically separates the sample filenames into groups based on the specified Section Separators. 
 
Group Identification:  Identifies how to match the filenames into groups based on the section entered into the 
Compare by Section field.  The section of the filename specified will be highlighted red in the File Name List. 
 
Control Identification:  Identifies which section of the filename contains the reference vs. sample information 
based on the section number entered in the Match to Identifier by Section field. The section of the filename 
specified will be highlighted green in the File Name List. 
  

 
Match by Fixed Position    
Allows the user to manually identify the characters of the filename 
for grouping the samples.  Section Separators like “_ , -“ are counted 
as individual characters. 
 
Group Identification:  Enter the number of the beginning and ending 
character to identify how to group the samples. The section of the 
filename specified will be highlighted red in the File Name List. 
 
Control Identification:  Enter the number of the beginning and ending 
character to identify which part of the filename contains the control 
identifier.  The section of the filename specified will be highlighted 
green in the File Name List. 
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Match by Group Order 
Allows the user to group samples that contain sequential 
identifiers.  
 
Group Size: Enter the number of groups for the analysis.  Standard 
MS-MLPA analysis would use 2 groups, an LOH analyses 
comparing one normal sample to three grades of tumor would use 
4 groups. 
 
 
 

Control Identifier  
Enter the character from the Control Identification section (highlighted green) that describes the control or 
reference sample.  Example: N = normal or R = reference.  Select Case Sensitive if the Control Identifier needs to 
be identified by upper or lower case letters. 
 

Control Match Mode 
Choose either Whole Words or Include.   
Whole Words should be used if the characters entered into the Control Identifier field need to match exactly.   
Include should be selected if the characters in the Control Identifier field only need to be identified in the filename, 
i.e. not an exact match. 
 
 
 
 
 

Filename Group Editor 
Tools → File Name Group Tool OR Project → Apply Sample Grouping 
 
The Filename Group Editor was originally developed to be used in conjunction with the Microsatellite Instability 
and Loss of Heterozygosity applications where tumor samples are compared to normal samples from the same 
patient.  Additionally, the Filename Group Editor can be used in the Main Analysis window Sample File Tree. 
 
 

Procedure 
1. Select Tools → File Name Group Tool OR Project → Apply 

Sample Grouping 
2. The File Name Group Editor window appears 
3. Click the Load Files icon and select all files to pair 
4. Choose Match by Sections or Match by Fixed Position or 

Group by Order 
5. Enter values for the Group Identification and Control 

Identification fields 
6. Enter a Control Identifier value and click Match 
7. The samples from the File Name List will be paired into 

groups in the Matched Groups window 
8. When the samples are paired correctly, click the Save 

Groups to File icon  
9. Save the group information as a tab-delimited Text (.txt) file 
10. Upload this filename group file into the Group File fields of the MSI or LOH analysis settings box OR the 

grouping will automatically be applied if Project → Apply Sample Grouping was chosen. 
 

Icons and Functions 
 

Load Files 
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Opens a directory window where raw data files can be located and uploaded to the Filename Group Editor 
 
Add Files 
Opens a directory window where additional raw data files can be uploaded into the Filename List field 
 
Remove Files 
Removes any files selected in the Filename List.  Select multiple files to remove by holding down the 
SHIFT key and selecting additional samples 

 
Save Groups to File  
Saves the filenames of the samples paired in the Matched Groups field.  Samples identified as Controls 
will be in the first column of the Matched Groups tab-delimited Text file.   

 

Match by Sections 
Automatically separates the sample filenames into groups 
based on the specified Section Separators. 
 
Group Identification:  Identifies how to match the filenames into 
groups based on the section entered into the Compare by Section 
field.  The section of the filename specified will be highlighted 
red in the File Name List. 
 
Control Identification:  Identifies which section of the filename 
contains the reference vs. sample information based on the 
section number entered in the Match to Identifier by Section field. 
The section of the filename specified will be highlighted green in the File Name List. 
  

 
Match by Fixed Position    
Allows the user to manually identify the characters of the filename 
for grouping the samples.  Section Separators like “_ , -“ are counted 
as individual characters. 
 
Group Identification:  Enter the number of the beginning and ending 
character to identify how to group the samples. The section of the 
filename specified will be highlighted red in the File Name List. 
 
Control Identification:  Enter the number of the beginning and ending 
character to identify which part of the filename contains the control 
identifier.  The section of the filename specified will be highlighted 
green in the File Name List. 
 
 
 

Match by Group Order 
Allows the user to group samples that contain sequential 
identifiers.  
 
Group Size: Enter the number of groups for the analysis.  Standard 
MS-MLPA analysis would use 2 groups, an LOH analyses 
comparing one normal sample to three grades of tumor would use 
4 groups. 
 
 
 

Control Identifier  
Enter the character from the Control Identification section (highlighted green) that describes the control or 
reference sample.  Example: N = normal or R = reference.  Select Case Sensitive if the Control Identifier needs to 
be identified by upper or lower case letters. 



Chapter 8  Additional Tools 

166 
2010 

 

Control Match Mode 
Choose either Whole Words or Include.   
Whole Words should be used if the characters entered into the Control Identifier field need to match exactly.   
Include should be selected if the characters in the Control Identifier field only need to be identified in the filename, i.e. not an 
exact match. 

 

Output Trace Data 
Tools → Output Trace Data 
 
The Output Trace Data tool exports raw or sized data of uploaded sample 
files as Text (.txt) or SCF (.scf) files.   
 

Procedure  
1. Select whether to export the data as a Text or SCF file 
2. Choose the directory and folder to save the exported data to in the 

Output File Name field. 
3. Select the samples to include in the output file from the Select Samples 

field. 
4. Select which dye color data to export from the Select Dyes field. 
5. Select whether to export raw or sized data from the Data Type options. 
6. Click Export to export the data to the specified folder. 
 

Project Comparison 
Tools → Project Comparison 
The Project Comparison tool can serve two functions.  First, it can be used to compare two independent analysts’ 
analyses.  Second, it can be used as a validation tool to determine differences in allele calls based on analysis 
parameters or instrument runs. 
 

Procedure  
1. After initial dataset analysis, select Tools → Project Comparison 
2. The Project Comparison window appears 
3. Click the Open Project to Compare icon 
4. Use the file directory window to locate and select a previously saved SoftGenetics project file (.sgf, .sfp) 
NOTE: Projects with similar datasets and analysis types should be chosen. 
5. Click Open and the second project will be uploaded to the Project Comparison tool 
6. The first project originally loaded into GeneMarker will be marked as the Reference (R=>) and the second 

project uploaded to the Project Comparison tool is marked as the Sample (S=>) 
7. Click the Project Comparison Settings icon to choose parameters to compare between the projects 
8. Differences will be indicated in the report table on the right.  When a difference is selected, each project’s 

electropherogram and peak table will be displayed on the left. 

Project Comparison Tool 
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Icons and Functions  
 

Open Project to Compare 
Opens a directory window for the user to identify a similar project to compare to the project already 
running in GeneMarker.  The first project in GeneMarker will be considered the Reference project and 

the project uploaded to the Project Comparison tool will be considered the Sample project 
Project Comparison Settings   
Launches the Project Comparison Settings box with several 
options for running the comparison. 

 
Peak Matched By: Allows the user to choose the principal parameters 
for comparison.   
 
Peak Compare Items: Options for which parameters should be 
compared and marked as different. 
 
Peak Comparison Threshold: Allows the user to qualify the ranges for 
detecting differences in peak attributes. 

 
 
 
File Grouping Tool 

Provides the ability to group duplicate files with different file names analyzed from different genetic 
analyzers. . If the projects have different file names they will appear in a list at the right side of the 
screen after selecting in the open folder process described above. Use the file group tool > match by 
section or fixed position > ‘Match’ > ‘OK’ 
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Convert TXT to Binary 
Tools → Convert Text to Binary Files 
 
The Convert Text to Binary tool allows the user to upload trace data information in Text (.txt) file format for 
conversion into a four-color SCF file or a five-color SG1 file.  The SCF and SG1 files can then be read by 
GeneMarker and translated into chromatograms.  This tool is useful for institutions developing their own 
fragment analysis instruments. 
 

Procedure 
1. Click the Load Text File button and select Text (.txt) files to 

convert 
2. Once files are uploaded, they will appear in the Text File 

field  
3. The software will automatically calculate a Recommended 

Ratio for the user to condense the number of frames in a 
single trace 

4. Enter a condense frames by XX number in the Condense 
Frames field 

5. Click Export to SG1 if exporting a five-color trace, click 
Export to SCF if exporting a four-color trace. 

 

 
Export Elecropherogram 
Tools →Export Electropherogram 
 
The Export Electropherogram tool allows the user to 
export the trace images to a specified folder. 
 

Procedure 
1. Use a dropdown menu to specify the output folder.  
2.  Specify the prefix and suffix for the exported file 

name. The full file name will be Prefix+Sample 
name+”_”+Dye name+Suffix+Extension name.  

3. Select samples, Dyes and Image Size 
4. Use a dropdown menu to specify the export format. 

JPEG and PNG are both available. PNG is 
recommended  
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Overview 
 
User management may be implemented after installation of GeneMarker. The 
administrator activates User Management from the Help drop-down menu. User 
management provides control of user access rights, automatically generates an 
audit trail of all edits to genotyping projects and is used to populate the 
Organization and Operator fields in print reports such as MLPA and Trisomy. 
 

Procedure  
1. Select Help → User Management 
2. The Login box appears 
3. Click Run User Protection to activate the Setup Administrator 
4. Enter Organization, an Administrator username and password 
5. Click OK 
6. You are now logged in as the Administrator 
7. Click the Add User button to add additional users 
8. Click the Access Rights button to set up user type access permissions 
9. Be sure to select Run User Protection and click OK to exit 
 

User Manager 
The User Manager tab displays user information and contains options for creating and deleting users. 
 
User Window 
Displays all users by name, type and creation date 
 
Organization 
Enter your organization name 
 
Run User Protection 
When selected, users will be prompted to log on with a user 
name and password.  When deselected, any person can launch 
GeneMarker without a username and password. 
 
Add User 
Launches the Add User box where a new username and 
password can be input.  This is also where the user type can be 
chosen.  A user can be deleted by right-clicking the username 
and selecting Delete User.   
NOTE: Only the Administrator can add and delete users. 
 
My Password 
Launches the Change Password box where the user that is logged in can 
enter a new password.  The new password must be entered twice to 
ensure accuracy. 
 
Access Rights 
Launches the Access Rights of User Types box where the different access 
rights available to each user type can be identified.  Clicking the Set 
Default button will return the Access Rights for the User Type selected 
back to factory defaults. 
NOTE: Only the Administrator can change Access Rights for a User 
Type. 
 
Change User 
Prompts for a confirmation of action then launches the Login box.  
Choose a new user and enter the user’s password to login. 
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History  
The User Manager History tab monitors user activity associated with 
the user manager function. 
 
Date/Time  
Records the computer’s date and time for the activity. 
 
User 
Identifies the username of the person that performed the activity. 
 
 
 
Events 
Records the user manager activity that was performed. 
 
Comments 
Gives additional information for the event that was performed.  For example, if a user is added, then the 
username of the person that was added is recorded under Comments. 
 

Settings  
The User Manager Settings tab contains additional options for the User 
Management function. 
 
Overtime Protection 
When selected, GeneMarker will logout the user after the specified 
time entered in the Wait field.  When the user is logged out, the status 
of the analysis remains unchanged until the user logs back in (with 
username and password).   
 
Record Data Edit History 
When selected, any changes made to the allele calls of the project will 
be saved in the Edit History log.  Please see Edit History section below 
for more information. 
 

Edit History/Audit Trail 
When Record Data Edit History is selected in the User Manager Settings box (see User Management Settings 
section above), any change to allele calls in the analysis will be recorded.  Changes can also be recovered in the 
Edit History feature. 
 
Procedure  
1. Click the Show Chart/Table icon in the Main Analysis window. 
2. The Peak Table will appear below the sample electropherogram. 
3. Make changes to allele calls by right-clicking any cell in that 

allele’s row in the Peak Table or right-click the grey vertical bar 
at the center of the peak in the electropherogram. 

4. Choose to Edit Allele, Edit Comments, Add/Delete Allele, and 
Confirm. See Chapter 3 Main Analysis Overview. 

5. Once a change has been made to the allele call, notice the pink 
shading in the No. column of the Peak Table.  This indicates a 
change has been made to that allele. 

6. Right-click any changed allele and select View History. 
7. The Show Edit History window appears. 
8. Select a change from the Edit History List to view changes in the 

Current/Old Values table.  Changes will be highlighted in red. 
9. To recover a change, right-click the row in the Edit History List and select Recover Old Value.  A star will 

appear in the Recover column. 
10. Click OK and click Yes when the warning prompts you to confirm.  
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Edits History Window 
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